A Apple admitiu que o seu sistema operativo Mac OS X 10.5, conhecido como Leopard, oferecia uma versão antiga da Java com vulnerabilidades de segurança e disponibilizou para download uma actualização de correcção.

O update corrige falhas que permitiam a execução de código malicioso, além de causarem bloqueios no sistema, provocando o mau funcionamento das aplicações, entre outras consequências.

A correcção actualiza o Leopard para as versões Java 1.6.0_15, 1.5.0_20 e 1.4.2_22, disponibilizada pela Sun Microsystems a 5 de Agosto último.

Ao que a imprensa internacional indica, de fora terá ficado uma correcção para aqueles que ainda utilizam a versão mais antiga do sistema operativo, a Tiger.

Estará igualmente por corrigir, uma vulnerabilidade no novissímo Snow Leopard, que também inclui uma versão antiga, desta vez relativa à tecnologia Flash da Adobe. Ao fazerem a actualização para o Snow Leopard, os utilizadores acabam por fazer um "downgrade" para a versão 10.0.23.1 do Flash, que poderá trazer vários problemas de segurança, alerta a Sophos.

Não perca as principais novidades do mundo da tecnologia!

Subscreva a newsletter do SAPO Tek.

As novidades de todos os gadgets, jogos e aplicações!

Ative as notificações do SAPO Tek.

Newton, se pudesse, seguiria.

Siga o SAPO Tek nas redes sociais. Use a #SAPOtek nas suas publicações.